Follow

Installing library on Linux

To be able to run Yousician on Linux, you need to make sure the needed libraries are installed. The libraries required to run Yousician are libc++ and libc++abi. To install them, run these commands on the terminal:

# Ubuntu 16.10

sudo apt-get update
sudo apt-get install libc++1 libc++abi1

# Ubuntu 16.04

sudo apt-get update
sudo apt-get install libc++1 libc++abi1

# Ubuntu 14.04

Step 1:
sudo bash -c "cat >> /etc/apt/sources.list" << LLVMAPT
deb http://llvm.org/apt/trusty/ llvm-toolchain-trusty main
deb http://llvm.org/apt/trusty/ llvm-toolchain-trusty-3.8 main
deb-src http://llvm.org/apt/trusty/ llvm-toolchain-trusty-3.8 main
LLVMAPT

Step 2:
wget -O - http://llvm.org/apt/llvm-snapshot.gpg.key|sudo apt-key add -

Step 3:
sudo apt-get install libc++1 libc++abi1

Was this article helpful?
0 out of 2 found this helpful
Have more questions? Submit a request
Powered by Zendesk